Задать вопрос
7 ноября, 06:50

Помогите с иформатикой в системе Pascal

Составить программу

вывода на экран всех

элементов массива,

оканчивающихся

нулем.

+1
Ответы (1)
  1. 7 ноября, 10:22
    0
    Const

    n=15;

    var

    a:array[1 ... n] of integer;

    i:integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    for i:=1 to n do begin

    a[i]:=Random (35) + 1;

    Write (a[i],' ')

    end;

    Writeln;

    Write ('Элементы, оканчивающиеся нулем: ') ;

    for i:=1 to n do

    if a[i] mod 10=0 then Write (a[i],' ')

    end.

    Пример

    Исходный массив

    8 28 35 25 35 1 20 14 30 4 2 15 20 2 13

    Элементы, оканчивающиеся нулем: 20 30 20
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с иформатикой в системе Pascal Составить программу вывода на экран всех элементов массива, оканчивающихся нулем. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10.
Ответы (1)
Cоставить алгоритм и программу для: 1) Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран! 2) Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) составьте программу ввода элементов массива а[1 ... 8 ] с клавиатуры и вывода на экран элементов с отрицательными значениями; 2) составьте программу ввода элементов массива b[1 ...
Ответы (1)