Задать вопрос
18 мая, 07:33

Помогите, как составить программу которая формирует массив из 16 случайных чисел от - 20 до 20 и определяет если в этом массиве хотя бы одно число кратное трём

+4
Ответы (1)
  1. 18 мая, 09:39
    0
    Var a:array[1 ... 16]of integer;

    i, k:integer;

    begin

    for i:=1 to 16 do begin a[i]:=random (41) - 20; write (a[i],' ') ; end;

    for i:=1 to 16 do if (a[i] mod 3=0) and (a[i]0) then begin writeln ('est') ; k:=1; break; end;

    if k1 then writeln ('net') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите, как составить программу которая формирует массив из 16 случайных чисел от - 20 до 20 и определяет если в этом массиве хотя бы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу которая формирует массив из шестнадцати случайных целых чисел от - 20 до 20 и определяет, есть ли в этом массиве хотя бы одно число, кратное трём
Ответы (2)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Составьте программу которая формирует массив из 16 случайных целых чисел от - 20 до 20 и находит в этом массиве индексы элементов значения которых кратны трём
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)