Задать вопрос
9 сентября, 12:46

Поменять местами максимальное и минимальное 3 хзначное число х (Pascal) Типо 157=751

+1
Ответы (1)
  1. 9 сентября, 14:58
    0
    Интересная задачка, заковыристая ...

    Var x, i, c, q, p:integer; s:string; max, min, k:char;

    Begin

    readln (x) ;

    str (x, s) ;

    max:=s[1];

    min:=s[1];

    p:=1; q:=1;

    for i:=2 to length (s) do

    begin

    if s[i]>max then

    begin

    max:=s[i];

    q:=i;

    end;

    if s[i]
    begin

    min:=s[i];

    p:=i;

    end;

    end;

    k:=s[p];

    s[p]:=s[q];

    s[q]:=k;

    val (s, x, c) ;

    writeln (x) ;

    End.

    Сработает для чисел любой значности.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Поменять местами максимальное и минимальное 3 хзначное число х (Pascal) Типо 157=751 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Даны 2 числа в двоичном виде. В первом числе поменять местами старшую и младшую части числа. Во втором - 1-ый и 4-ый разряды поменять местами с 3-м и 7-мым разрядами соответственно. Результаты логически сложить и умножить на 4.
Ответы (1)
Составить программу в массиве с N числами поменять местами максимальное и минимальное значения
Ответы (1)