Задать вопрос
24 октября, 13:06

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения

+1
Ответы (1)
  1. 24 октября, 14:35
    0
    Var

    a:array[1 ... 1000] of integer;

    i, min, max, c, n:integer;

    begin

    read (n) ;

    min:=1; max:=1;

    for i:=1 to n do read (a[i]) ;

    for i:=1 to n do begin

    if a[i]>a[max] then max:=i;

    if a[i]
    end;

    c:=a[min];

    a[min]:=a[max];

    a[max]:=c;

    for i:=1 to n do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в массиве с N числами поменять местами максимальное и минимальное значения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы