Задать вопрос
26 марта, 11:00

В массиве четное количество элементов поменять местами в массиве 1 с последним 2 с предпоследним и т. д

+2
Ответы (1)
  1. 26 марта, 12:48
    0
    Const NN=50;

    var

    a:array [1 ... NN] of integer;

    i, n, k:integer;

    begin

    write ('Введите кол-во эл-тов массива: ') ;

    readln (n) ;

    for i: = 1 to n do

    begin

    a[i]:=random (50) ;

    write (a[i],' ') ;

    end;

    writeln;

    for i: = 1 to n div 2 do

    begin

    k:=a[i];

    a[i]:=a[n-i+1];

    a[n-i+1]:=k;

    end;

    for i: = 1 to n do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве четное количество элементов поменять местами в массиве 1 с последним 2 с предпоследним и т. д ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Антон сортирует по возрастанию список из 10 элементов: 6 12 3 4 9 2 10 11 7 5 Ему разрешается поменять местами любые два элемента, но за такой обмен ему придется отдать количество конфет, равное разности позиций обмениваемых элементов (позиции
Ответы (1)
1. Дан массив из 20 элементов, принимающих значения от 0 до 50. Найти количество элементов, больших 25 и сумму элементов, меньших 25. 2. Найти в массиве наибольший элемент и поменять его местами с первым элементом.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Даны 2 числа в двоичном виде. В первом числе поменять местами старшую и младшую части числа. Во втором - 1-ый и 4-ый разряды поменять местами с 3-м и 7-мым разрядами соответственно. Результаты логически сложить и умножить на 4.
Ответы (1)