Задать вопрос
22 сентября, 15:06

Составьте программу которая формирует массив из шестнадцати случайных целых чисел от - 20 до 20 и определяет, есть ли в этом массиве хотя бы одно число, кратное трём

+1
Ответы (2)
  1. 22 сентября, 16:31
    -1
    var a:array[1 ... 16]of integer;

    i, k:integer;

    begin

    for i:=1 to 16 do begin a[i]:=random (41) - 20; write (a[i],' ') ; end;

    for i:=1 to 16 do if (a[i] mod 3=0) and (a[i]0) then begin writeln ('est') ; k:=1; break; end;

    if k1 then writeln ('net') ;

    end.
  2. 22 сентября, 18:58
    0
    var

    a: array [1 ... 16] of integer; / / Массив из 16 целых чисел

    i: integer;

    b: boolean; {Логическая переменная (найдено ли хотя бы одно число, кратное трем) }

    begin

    b: = false; / / Ни одного числа, кратного трем еще не найдено

    write ('Исходный массив: ') ;

    for i: = 1 to 16 do {Заполняем исходный массив случайными числами от - 20 до 20 и распечатываем его}

    begin

    a[i]: = random (40) - 20;

    write (a[i], ' ') ;

    end;

    writeln;

    for i: = 1 to 16 do / / Определяем, есть ли в массиве хотя бы одно число, кратно трём, и если есть, то выходим из цикла

    if (a[i] mod 3 = 0) and (a[i] 0) then

    begin

    writeln ('В массиве есть хотя бы одно число, кратное трём') ;

    b: = true;

    break;

    end;

    if b = false then writeln ('В массиве нет ни одного числа, кратного трём') ;

    end.

    Если все правильно, отметь решение как лучшее)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая формирует массив из шестнадцати случайных целых чисел от - 20 до 20 и определяет, есть ли в этом массиве хотя ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)
Помогите, как составить программу которая формирует массив из 16 случайных чисел от - 20 до 20 и определяет если в этом массиве хотя бы одно число кратное трём
Ответы (1)
Составьте программу, которая формирует массив из шестнадцати целых чисел от - 20 до 20 и находит в этом массиве индексы элементов, значения которых кратным трём.
Ответы (2)
Составьте программу которая формирует массив из 16 случайных целых чисел от - 20 до 20 и находит в этом массиве индексы элементов значения которых кратны трём
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)