Задать вопрос
13 июня, 04:56

Составьте программу, которая формирует массив из шестнадцати целых чисел от - 20 до 20 и находит в этом массиве индексы элементов, значения которых кратным трём.

+5
Ответы (2)
  1. 13 июня, 07:20
    0
    var

    i:integer;

    a:array[1 ... 16]of integer;

    begin

    for i:=1 to 16 do

    begin

    a[i]:=random (40) - 20;

    if a[i] mod 3=0 then write (i,' ') ;

    end;

    writeln;

    end.
  2. 13 июня, 07:54
    0
    Как-то так ...

    Program g;

    Var

    A, B : Integer;

    N : Integer;

    S : Integer;

    z:array[0 ... 16] of integer;

    i : Integer;

    v:integer;

    Begin

    A: = (-20) ;

    B:=20;

    N:=16;

    For i : = 1 To N Do

    Begin

    S : = Trunc (Random (B-A) + A) ;

    WriteLn (i:2,'-е случайное число:', S:4) ;

    End;

    begin

    writeln ('Индексы элементов кратных 3:') ;

    for v:=0 to 16 do begin

    z[v]:=random (40) - 20;

    if z[v] mod 3 = 0 then write (v, ' ')

    end;

    end;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая формирует массив из шестнадцати целых чисел от - 20 до 20 и находит в этом массиве индексы элементов, значения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)
Составьте программу которая формирует массив из 16 случайных целых чисел от - 20 до 20 и находит в этом массиве индексы элементов значения которых кратны трём
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Составьте программу, которая формирует массив из шестнадцати чисел от - 20 до 20 и находит индексы четных элементов.
Ответы (1)
Составьте программу которая формирует массив из шестнадцати случайных целых чисел от - 20 до 20 и определяет, есть ли в этом массиве хотя бы одно число, кратное трём
Ответы (2)