Задать вопрос
16 апреля, 18:00

Составте программу позволяющую подсчитать в массиве число положительных и нулевых элементов

+3
Ответы (1)
  1. 16 апреля, 20:38
    +1
    Program rok;

    var a:array [1 ... 30] of integer;

    i, s, n:integer;

    begin

    s:=0;

    n:=0;

    randomize;

    for i:=1 to 30 do begin

    a[i]:=random (25) - 10;

    write (a[i],' ') ;

    end;

    writeln;

    for i:=1 to 20 do begin

    if (a[i]>0) then s:=s+1;

    if (a[i]=0) then n:=n+1;

    end;

    writeln ('Количество положительных чисел=', s) ;

    writeln ('Количество нулей=', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте программу позволяющую подсчитать в массиве число положительных и нулевых элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив из N целочисленных элементов. найти максимальное количество подряд идущих нулевых элементов. Гарантируется, что в массиве есть хотя бы одна пара рядом стоящих нулевых элементов.
Ответы (1)
25. Дан одномерный массив. Подсчитать количество положительных и отрицательных элементов. Нулевых элементов в массиве нет.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
Составить программу (в Pascal) позволяющую найти минимальный элемент массива. Подсчитать количество элементов в массиве, равных минимальному. Размеренность массива произвольная.
Ответы (2)