Задать вопрос
7 января, 21:03

Составить программу (в Pascal) позволяющую найти минимальный элемент массива. Подсчитать количество элементов в массиве, равных минимальному. Размеренность массива произвольная.

+5
Ответы (2)
  1. 7 января, 21:42
    0
    Uses crt;

    const N=10;

    var a:array [1 ... N] of integer;

    x, min, k:integer;

    begin

    for x:=1 to N do

    begin

    write ('a[', x,']:', a[x]) ;

    readln (a[x]) ;

    end;

    min:=a[1];

    for x:=1 to N do

    if a[x]
    for x:=1 to N do

    if a[x]=min then inc (k) ;

    writeln ('Минимальный элемент: ', min,'. Таких элементов в массиве: ', k) ;

    end.
  2. 7 января, 22:46
    0
    Program my;

    var k, i, z:integer;

    a:array[1 ... N]:integer;

    begin

    k:=99999;

    for i:=1 to N do

    if a[i]
    z:=0;

    for i:=1 to N do

    if a[i]=k then z:=z+1;

    end.

    =)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу (в Pascal) позволяющую найти минимальный элемент массива. Подсчитать количество элементов в массиве, равных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)