Задать вопрос
21 декабря, 05:24

Дан массив из N целочисленных элементов. найти максимальное количество подряд идущих нулевых элементов. Гарантируется, что в массиве есть хотя бы одна пара рядом стоящих нулевых элементов. Ответ представить на алгоритмическом языке или любом языке программирования. укажите используемую версию языка программирования.

+4
Ответы (1)
  1. 21 декабря, 08:31
    0
    Язык Паскаль АБС нэт

    var

    a:array[1 ... 100] of integer;

    b:array[1 ... 50] of integer;

    i, c, s, n:integer;

    begin

    read (n) ;

    for i:=1 to n do a[i]:=random (3) ; write (a[i]:3) ;

    i:=0;

    while i
    i+=1;

    if a[i] = 0 then s+=1;

    if (a[i] 0 and s > 0) or (i=n) then begin

    c+=1;

    b[c]:=s;

    s:=0;

    end;

    end;

    for i:=1 to n do begin

    write (b[i]:3) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N целочисленных элементов. найти максимальное количество подряд идущих нулевых элементов. Гарантируется, что в массиве есть ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)