Задать вопрос
11 октября, 19:00

Ввести целое число, найти его квадрат, не используя операцию умножения.

(Составьте алгоритм)

+5
Ответы (1)
  1. 11 октября, 22:51
    0
    Var a, a2, i:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    a2:=0;

    for i:=1 to a do a2:=a2+a;

    writeln (a,'^2 = ', a2) ;

    end.

    Пример:

    a = 7

    7^2 = 49
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести целое число, найти его квадрат, не используя операцию умножения. (Составьте алгоритм) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы в Pascal: 1. Ввести целое число и определить, верно ли, что все его цифры расположены в порядке возрастания ... 2. Ввести целое число и "перевернуть" его, так чтобы первая цифра стала последней и т. д.
Ответы (1)
Написать алгоритм вычисления y по формуле y=1-x^2 + 5x^4, где x - данное целое число. Учесть следующее ограничения 1) можно использовать только операции сложения, умножения, вычитания. 2) в каждом выражении можно использовать только 1 операцию
Ответы (1)
Напиши программу. Дано целое число N (N > 0). Найти сумму (N + 1) ^2 + (N + 2) ^2 + ... + (2•N) ^2 Входные данные: ввести целое число N (1
Ответы (1)
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)
Первое задание дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры второе задание дано целое трёхзначное число x.
Ответы (1)