Задать вопрос
24 июля, 14:16

Дано натуральное четырехзначное число, верно ли, что все его цифры различны?

+4
Ответы (1)
  1. 24 июля, 14:40
    0
    var a, b, c, d, e:integer;

    begin

    read (a) ;

    b:=a mod 10;

    a:=a div 10;

    c:=a mod 10;

    a:=a div 10;

    d:=a mod 10;

    a:=a div 10;

    e:=a mod 10;

    if (bc) and (bd) and (be) and (cd) and (ce) and (de) then write ('net povtorov')

    else write ('est povtori') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное четырехзначное число, верно ли, что все его цифры различны? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число n (n < 9999). Выяснить, различны ли все четыре цифры этого числа (с учетом четырех цифр). Например, в числе 3678 все цифры различны, в числе 0023 - нет.
Ответы (1)
Дано натуральное четырехзначное число, верно ли, что все его цифры различны? Написать программу.
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
C + + Дано натуральное четырехзначное число. Найдите минимальное натуральное четырехзначное число, состоящее из тех же цифр, что и заданное. Заметим, что четырехзначные числа не могут начинаться с нуля.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)