Задать вопрос
27 января, 15:41

Дано натуральное четырехзначное число, верно ли, что все его цифры различны? Написать программу.

+1
Ответы (1)
  1. 27 января, 17:10
    0
    var a, b, c, d, e:integer;

    begin

    read (a) ;

    b:=a mod 10;

    a:=a div 10;

    c:=a mod 10;

    a:=a div 10;

    d:=a mod 10;

    a:=a div 10;

    e:=a mod 10;

    if (bc) and (bd) and (be) and (cd) and (ce) and (de) then write ('net povtorov')

    else write ('est povtori') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное четырехзначное число, верно ли, что все его цифры различны? Написать программу. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Дано натуральное число n (n < 9999). Выяснить, различны ли все четыре цифры этого числа (с учетом четырех цифр). Например, в числе 3678 все цифры различны, в числе 0023 - нет.
Ответы (1)
Дано натуральное четырехзначное число, верно ли, что все его цифры различны?
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)