Задать вопрос
24 января, 04:32

Решите задачу на паскале! В промежутке [m, n] найти все числа, в записи которых нет цифры b.

+2
Ответы (2)
  1. 24 января, 04:43
    0
    Program Program1;

    var

    i, n, m, b:integer;

    s, s1:string;

    Begin

    write ('Введите значение m: ') ;

    readln (m) ;

    write ('Введите значение n: ') ;

    readln (n) ;

    write ('Введите значение b: ') ;

    readln (b) ;

    str (b, s) ;

    for i:=m to n do

    begin

    str (i, s1) ;

    if pos (s, s1) = 0 then writeln (i) ;

    end;

    end.
  2. 24 января, 04:54
    0
    Program Pr1;

    uses crt;

    var mas:array[byte] of integer;

    i, n, m, b, a, c:integer;

    tmp, tmp1:string;

    Begin

    clrscr;

    writeln ('Введите промежуток и число') ;

    readln (m, n, b) ;

    str (b, tmp) ;

    for i:=m to n do begin

    c:=0;

    tmp1:='';

    str (i, tmp1) ;

    for a:=1 to length (tmp1) do if tmp1[a]tmp[1] then c:=c+1;

    if c=length (tmp1) then writeln (i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите задачу на паскале! В промежутке [m, n] найти все числа, в записи которых нет цифры b. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Сколько единиц в двоичной записи числа 67,5? 2) Сколько единиц в двоичной записи числа 23,375? 3) Сколько значащих нулей в двоичной записи числа 19,125? 4) Сколько значащих нулей в двоичной записи числа 37,875?
Ответы (1)
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
Помогите решить задачи в паскале: 3 9. Найти произведение целых нечетных чисел в промежутке [m, n], где m, n-произвольные вещественные числа (вводятся с клавиатуры). 10.
Ответы (1)
Вывести на экран и посчитать количество всех четырехзначных чисел, в записи которых нет одинаковых цифр, и все цифры идут в убывающем порядке. на паскале
Ответы (1)
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.
Ответы (1)