Задать вопрос
8 ноября, 02:42

Помогите решить задачи в паскале: 3

9. Найти произведение целых нечетных чисел в промежутке [m, n], где m, n-произвольные вещественные числа (вводятся с клавиатуры).

10. Найти все степени числа 2 в промежутке [m, n], где m, n-произвольные целые числа (вводятся с клавиатуры).

+2
Ответы (1)
  1. 8 ноября, 05:05
    0
    Var

    m, n, p:real;

    k:integer;

    begin

    Write ('Введите через пробел начало и конец интервала: ') ;

    Read (m, n) ;

    p:=1;

    k:=Trunc (m) ;

    if (k mod 2) = 0 then Inc (k) ; { Первое нечетное }

    n:=Int (n) ; { целочисленный конец интервала }

    while k<=n do

    begin p:=p*k; k:=k+2 end;

    Writeln ('Произведение нечетных на интервале: ', p)

    end.

    Тестовое решение:

    Введите через пробел начало и конец интервала: - 3.8 8.2

    Произведение нечетных на интервале: 315

    var

    m, n, i, j:integer;

    p:real;

    begin

    Write ('Введите через пробел целочисленные границы интервала: ') ;

    Read (m, n) ;

    for i:=m to n do

    begin

    p:=1;

    if i=0 then Writeln ('2^0=1')

    else

    if i<0 then

    begin for j:=-1 downto i do p:=p/2; Writeln ('2^ (', i,') = ', p) end

    else

    begin for j:=1 to i do p:=p*2; Writeln ('2^', i,'=', p) end

    end

    end.

    Тестовое решение:

    Введите через пробел целочисленные границы интервала: - 5 10

    2^ (-5) = 0.03125

    2^ (-4) = 0.0625

    2^ (-3) = 0.125

    2^ (-2) = 0.25

    2^ (-1) = 0.5

    2^0=1

    2^1=2

    2^2=4

    2^3=8

    2^4=16

    2^5=32

    2^6=64

    2^7=128

    2^8=256

    2^9=512

    2^10=1024
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачи в паскале: 3 9. Найти произведение целых нечетных чисел в промежутке [m, n], где m, n-произвольные вещественные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Числа в языке Pascal различаются: А) как натуральные и целые; Б) как целые и вещественные; В) как натуральные и вещественные; Г) как целые и иррациональные; Д) как целые и рациональные.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
Паскаль 5.3 Напечатать "столбиком": а) все целые числа от 20 до 35 б) квадраты всех целых чисел от a до 50 (значение a вводится с клавиатуры; b>=10) в) третьи степени всех целых чисел от a до 50 (значение a вводится с клавиатуры; a
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)