Задать вопрос
5 апреля, 16:47

1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2.

2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5.

3. Определите сколько раз будет выполняться тело цикла, при вычислении:y=9a+a (sqr2) на промежутке [-3,2 ] с шагом 2.

4. Определите сколько раз будет выполняться тело цикла, при вычислении:y=15a+3 (sqr3) на промежутке [-1,2 ] с шагом 0,5.

И можно узнать как это сделать в PascalABC?

+5
Ответы (1)
  1. 5 апреля, 18:32
    0
    Исходя из самого вопроса - тут не важно само выражение функции.

    1. 7 { - 6, - 4, - 2, 0, 2, 4, 6 }

    Var k, n : Real;

    Begin

    n:=0;

    k:=-6;

    While k<=6 do

    Begin

    k:=k+2;

    n:=n+1;

    end;

    Writeln ('n = ', n) ;

    end.

    2. 7 { - 2, - 1.5, - 1, - 0.5, 0, 0.5, 1 }

    Var k, n : Real;

    Begin

    n:=0;

    k:=-2;

    While k<=1 do

    Begin

    k:=k+0.5;

    n:=n+1;

    end;

    Writeln ('n = ', n) ;

    end.

    3. 3 { - 3, - 1, 1 }

    Var k, n : Real;

    Begin

    n:=0;

    k:=-3;

    While k<=2 do

    Begin

    k:=k+2;

    n:=n+1;

    end;

    Writeln ('n = ', n) ;

    end.

    4. 7 { - 1, - 0.5, 0, 0.5, 1, 1.5, 2 }

    Var k, n : Real;

    Begin

    n:=0;

    k:=-1;

    While k<=2 do

    Begin

    k:=k+0.5;

    n:=n+1;

    end;

    Writeln ('n = ', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы