Задать вопрос
16 июля, 15:46

Написать прогу на паскале. Дано натуральное число n. Вычислить y=2*4*6 ... (2n).

+5
Ответы (1)
  1. 16 июля, 17:09
    0
    Program Program1;

    var

    i, n, y:integer;

    begin

    write ('Введите значение n: ') ;

    readln (n) ;

    i:=2;

    y:=1;

    while i<=2*n do

    begin

    y:=y*i;

    inc (i, 2) ;

    end;

    writeln ('y=', y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать прогу на паскале. Дано натуральное число n. Вычислить y=2*4*6 ... (2n). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Написать программу в паскале 1. Вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2, дано натуральное число n. Вычислить (1+1/12) &#61655; (1+1/22) &#61655; ...&#61655; (1+1/n2). 3. Дано целое число А.
Ответы (1)
Написать прогу на пвскале 6. Дано натуральное число N (N > 9). Определить количество нулей, идущих подряд в младших разрядах данного числа. Пример. N = 1020000. Количество нулей равно четырем.
Ответы (1)
Это цикл for: 1) даны натуральные числа X и Y. вычислить X*Y, пользуясь только оперцией сложения. 2) даны натуральные числа X и Y. вычислить X^Y 3) дано натуральное число N. найти сумму S=1+1/2+1/3 + ... + 1/N. 4) дано натуральное число N и число Х.
Ответы (1)
Определить максимальное трёхзначное целое число, которое нацело делится на 21. Вывести значения: делимое число, остаток от деления на 21 и целое частное для каждого шага алгоритма. Отдельной строкой вывести ответ. написать прогу в паскале
Ответы (1)