Задать вопрос
21 сентября, 05:39

Определить максимальное трёхзначное целое

число, которое нацело делится на 21.

Вывести значения: делимое число, остаток от деления на 21 и целое

частное для каждого шага алгоритма.

Отдельной строкой вывести ответ.

написать прогу в паскале

+3
Ответы (1)
  1. 21 сентября, 09:12
    0
    Program X;

    var

    max, i: longint;

    begin

    max:=0;

    for i : = 100 to 999 do

    begin

    writeln ('Делимое: ', i, ' Остаток: ', i mod 21, ' Целое частное: ', i div 21) ;

    if (i mod 21) = 0 then max : = i

    end;

    writeln ('Ответ: ', max)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить максимальное трёхзначное целое число, которое нацело делится на 21. Вывести значения: делимое число, остаток от деления на 21 и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Программа выполняется в Паскале! Дано целое число N (> 0). С помощью операций деления нацело и взятия остатка от деления определить, имеются ли в записи числа N нечетные цифры. Если имеются, то вывести True, если нет - вывести False. Помогите плииз.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)