Задать вопрос
13 августа, 10:39

Написать прогу на пвскале

6. Дано натуральное число N (N > 9). Определить количество нулей, идущих подряд в младших разрядах данного числа. Пример. N = 1020000. Количество нулей равно четырем.

+2
Ответы (1)
  1. 13 августа, 12:51
    0
    var N, i:integer;

    begin

    readln (n) ;

    while (n mod 10=0) do begin inc (i) ; n:=n div 10; end;

    writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать прогу на пвскале 6. Дано натуральное число N (N > 9). Определить количество нулей, идущих подряд в младших разрядах данного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число N (N> 9). Определить количество нулей в цифровой записи числа, кроме нулей в младших разрядах. Пример. N=10 025 000. Количество нулей равно двум.
Ответы (1)
N первых простых чисел представляются в двоичной системе счисления и записываются подряд. Из полученной последовательности нулей и единиц формируется числовая последовательность, каждый элемент которой представляет количество нулей, идущих подряд.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Лазарус: 1. Даны символы S1, S2, ..., Sn (вводятся одной строкой). а) подсчитать наибольшее количество идущих подряд введенных символов; б) выяснить, верно ли, что в последовательности S1, S2, ..., Sn имеются пять идущих подряд введенного символа.
Ответы (1)
Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N. Входные данные Задано единственное число N Выходные данные Необходимо вывести количество нулей среди всех цифр числа N.
Ответы (1)