Задать вопрос
14 октября, 09:24

Лазарус:

1. Даны символы S1, S2, ..., Sn

(вводятся одной строкой).

а) подсчитать наибольшее

количество идущих подряд введенных символов;

б) выяснить, верно ли, что в

последовательности S1, S2,

..., Sn имеются пять идущих подряд введенного символа.

+3
Ответы (1)
  1. 14 октября, 09:41
    0
    uses crt;

    var a, b, c, i, j, n:integer;

    s, k : array [1 ... 10000] of integer;

    begin

    clrscr;

    writeln ('Введите размер массива > 4.') ;

    read (n) ;

    for i:=1 to n do

    begin

    writeln ('Введите ', i, ' элемент.') ;

    read (s[i]) ;

    end;

    for i:=1 to n do

    for j:=1 to n-1 do

    while s[i]=s[j] do

    begin

    j:=j+1;

    inc (k[i]) ;

    end;

    a:=k[1];

    for i:=1 to n do

    if a
    a:=k[i];

    if k[i]=0 then k[i]:=1;

    writeln ('Наибольшая длина равных элементов идущих последовательно равна ', k[i], '.') ;

    for i:=1 to n-5 do

    if (s[i+4]-s[i+3]=1) and (s[i+3]-s[i+2]=1) and (s[i+2]-s[i+1]=1) and (s[i+1]-s[i]=1) then inc (b) ;

    if b=0 then writeln ('Нет 5 последовательны чисел.') else writeln ('Есть 5 последовательных чисел и это количество равно ', b) ;

    end.

    P. S. Надеюсь на благодарность и лучший ответ.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Лазарус: 1. Даны символы S1, S2, ..., Sn (вводятся одной строкой). а) подсчитать наибольшее количество идущих подряд введенных символов; б) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Даны натуральное число n, символы s1, ... sn., группы символов, разделённые пробелами (одним или несколькими) и не содержащие пробелов внутри себя, будем называть словами. подсчитать количество слов в данной последовательности. в TPascal
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)
N первых простых чисел представляются в двоичной системе счисления и записываются подряд. Из полученной последовательности нулей и единиц формируется числовая последовательность, каждый элемент которой представляет количество нулей, идущих подряд.
Ответы (1)