Задать вопрос
21 февраля, 14:25

Даны натуральное число n, символы s1, ... sn., группы символов, разделённые пробелами (одним или несколькими) и не содержащие пробелов внутри себя, будем называть словами. подсчитать количество слов в данной последовательности.

в TPascal

+5
Ответы (1)
  1. 21 февраля, 16:39
    0
    var

    s:string;

    i, count:integer;

    begin

    count:=0;

    readln (s) ;

    for i:=1 to length (s) do

    if (s[i]=' ') then count:=count+1;

    writeln ('В данной строке ', count+1,' слов') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральное число n, символы s1, ... sn., группы символов, разделённые пробелами (одним или несколькими) и не содержащие пробелов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка символов, груп символов разделенные пробелом (одним или несколькими) и не содержащие пробелолов внутри себя, будем называть словами.
Ответы (1)
Дана строка, содержащая слова, разделенные одним или несколькими пробелами. Написать программу, заменяющую каждый пробел символом"?"
Ответы (1)
Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток.
Ответы (1)
Напишите программу на паскаль. Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток.
Ответы (1)
Дана строка из нескольких слов, разделённых одним или несколькими пробелами. Напечатать эту строку без избыточных пробелов.
Ответы (1)