Задать вопрос
14 июля, 16:26

Задача 1

Составить программу

При поступлении в вуз абитуриенты, получившие "двойку" на первом экзамене, ко второму не допускаются. В массиве A[n] записаны оценки экзаменующихся, полученные на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену.

Задача 2

В одномерном массиве, состоящем из n вещественных элементов, вычислить;

1) минимальный элемент массива;

2) сумму элементов массива, расположенных между первым и последним положительными элементами.

Преобразовать массив таким образом, чтобы сначала располагать все элементы, равные нулю, а потом-все остальные.

+3
Ответы (1)
  1. 14 июля, 18:40
    0
    Задача1

    массив определи как array[];

    чтобы посчитать, просто используй счетчик, но сначала инициализируй переменную, которая содержит ответ задачи:

    int n;

    array [n];

    int answer;

    for (i=0, i < n, i++)

    {

    if (array[i] = = 2)

    answer++;

    }

    std::cout<
    Как то так

    Задача2

    array[n];

    for (int i = 1, i < n, i++)

    {

    if (array[0] > = array[i])

    array[0] = array[i];

    }

    std::cout << array[0];

    //Это было решение первого пункта

    int first;

    int last

    bool positive;

    while (positive = = false)

    {

    for (int i = 0; i < n; i++)

    {

    if (array[i] > 0)

    {

    positive = true;

    first = i;

    array[i] = - 1;

    }

    }

    while (positive = = false)

    {

    for (int i = 0, i < n, i++)

    {

    if (array[i] > 0)

    {

    positive = true;

    last = i;

    }

    }

    int summ

    for (int i = first, i < last, i++)

    {

    summ + = array[i];

    }

    std::cout<
    / / ПРеобразую

    newarray [n];

    int a = 0;

    for (int i = 0, i < n, i++)

    {

    if (array[i] = = 0)

    {

    newarray[a] = array[i];

    a++;

    }

    }

    for (int i = 0, i < n, i++)

    {

    if (array[i]! = 0)

    {

    newarray[a] = array[i];

    a++;

    }

    }

    std::cout<< newarray;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача 1 Составить программу При поступлении в вуз абитуриенты, получившие "двойку" на первом экзамене, ко второму не допускаются. В ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
При поступлении в ВУЗ абитуриенты, получившие "двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны фамилии экзаменующихся, а в массиве B[N] - их оценки, полученные на первом экзамене.
Ответы (1)
При поступлении в институт абитуриенты, получившие двойку на первом экзамене, ко второму недопускаются. В массиве А записаны оценки экзаменующихся. Подсчитать, сколько человек не допущено ко второму экзамену. "язык паскаль"
Ответы (1)
В одномерном массиве, состоящем из n вещественных элементов, вычислить: 1) Максимальный по модулю элемент массива 2) Сумму элементов массива, расположенных между первым и вторым положительными элементами.
Ответы (1)
В одномерном массиве, состоящем из n целых элементов, вычислить: 1.) минимальный по модулю элемент массива; 2.) сумму модулей элементов массива, расположенных после первого элемента, равного нулю.
Ответы (1)
Помогите написать программу Pascal! При поступлении в институт абитуриенты получившие "двойку" за первый экзамен, не допускаются до второго. Дан список абитуриентов и их оценки на первом экзамене.
Ответы (1)