Задать вопрос
25 апреля, 13:15

Помогите написать программу Pascal!

При поступлении в институт абитуриенты получившие "двойку" за первый экзамен, не допускаются до второго. Дан список абитуриентов и их оценки на первом экзамене. Составьте список абитуриентов допущенных ко 2 экзамену.

Дано:

n:=10

Массив А-Фамилии (записываются вручную) - string

Массив B-оценки random (4) + 1

Найти: Массив С[j]-string

+3
Ответы (1)
  1. 25 апреля, 16:48
    0
    Const n=10;

    var a:array [1 ... n] of string;

    b:array [1 ... n] of Integer;

    c:array [1 ... n] of string;

    i, j:Integer;

    begin

    Randomize;

    for i:=1 to n do

    readln (a[i]) ;

    for i:=1 to n do

    b[i]:=random (4) + 1;

    for i:=1 to n do

    begin

    if b[i]>2 then

    begin

    c[i]:=a[i];

    write (c[i],'-', b[i],' ') ;

    end;

    end;

    Readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу Pascal! При поступлении в институт абитуриенты получившие "двойку" за первый экзамен, не допускаются до ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
При поступлении в ВУЗ абитуриенты, получившие "двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны фамилии экзаменующихся, а в массиве B[N] - их оценки, полученные на первом экзамене.
Ответы (1)
Задача 1 Составить программу При поступлении в вуз абитуриенты, получившие "двойку" на первом экзамене, ко второму не допускаются. В массиве A[n] записаны оценки экзаменующихся, полученные на первом экзамене.
Ответы (1)
При поступлении в институт абитуриенты, получившие двойку на первом экзамене, ко второму недопускаются. В массиве А записаны оценки экзаменующихся. Подсчитать, сколько человек не допущено ко второму экзамену. "язык паскаль"
Ответы (1)
15. string s = "Я люблю программировать!"; int p = s. LastIndexOf ("") ; Console. WriteLine (p) ; 16. string s = "Я люблю программировать!"; string res=s. Remove (27) ; Console. WriteLine (res) ; 17.
Ответы (1)
Необходимо вывести числа от - 3 до 7. random (6) ; random (-3,7) ; random (-3) + 7; random (7) - 3.
Ответы (1)