Задать вопрос
25 марта, 12:58

При поступлении в ВУЗ абитуриенты, получившие "двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны фамилии экзаменующихся, а в

массиве B[N] - их оценки, полученные на первом экзамене. Вывести на экран фамилии абитуриентов, не допущенных ко второму экзамену. Протестировать программу на следующих исходных данных:

Массив A: Иванов Петров Орлов Соколов Воронова Гусева Алексеев

Массив B: 2 4 5 4 2 3 3

Протестировать программу на приведённом выше примере.

+5
Ответы (1)
  1. 25 марта, 15:41
    0
    Var

    i, n: integer;

    names: array[1 ... 100] of string;

    marks: array[1 ... 100] of byte;

    begin

    write ('n = ') ;

    readln (n) ;

    for i : = 1 to n do

    begin

    write ('Фамилия = ') ;

    readln (names[i]) ;

    write ('Оценка = ') ;

    readln (marks[i]) ;

    end;

    for i : = 1 to n do

    if marks[i] = 2 then

    writeln (names[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «При поступлении в ВУЗ абитуриенты, получившие "двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны фамилии ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 Составить программу При поступлении в вуз абитуриенты, получившие "двойку" на первом экзамене, ко второму не допускаются. В массиве A[n] записаны оценки экзаменующихся, полученные на первом экзамене.
Ответы (1)
Помогите написать программу Pascal! При поступлении в институт абитуриенты получившие "двойку" за первый экзамен, не допускаются до второго. Дан список абитуриентов и их оценки на первом экзамене.
Ответы (1)
При поступлении в институт абитуриенты, получившие двойку на первом экзамене, ко второму недопускаются. В массиве А записаны оценки экзаменующихся. Подсчитать, сколько человек не допущено ко второму экзамену. "язык паскаль"
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Напишите программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K. Протестировать программу на следующих исходных данных: а) k=3 Массив: 2 6 - 9 4 5 12 - 15 б) k=4 Массив: 9 0 8 124 - 16 11 19
Ответы (1)