Задать вопрос
25 февраля, 19:52

В одномерном массиве, состоящем из n вещественных элементов, вычислить:

1) Максимальный по модулю элемент массива

2) Сумму элементов массива, расположенных между первым и вторым положительными элементами.

Буду очень благодарен, если сделаете это задание!

+3
Ответы (1)
  1. 25 февраля, 22:01
    0
    Program E04;

    uses crt;

    var

    n, i, k, f: integer;

    X: array[1 ... 50] of real;

    Max, S: real;

    begin

    clrscr;

    writeln ('Введите размерность: ') ;

    readln (n) ;

    writeln ('Введите массив: ') ;

    for i:=1 to n do

    begin

    write ('X[', i:2,'] = = > ') ;

    readln (X[i])

    end;

    writeln ('Исходный массив: ') ;

    for i:=1 to n do

    write (X[i],' ') ;

    writeln;

    Max:=abs (X[1]) ;

    for i:=1 to n do

    if Max < = abs (X[i]) then

    Max:=abs (X[i]) ;

    writeln ('Максимальный элемент по модулю: ', Max) ;

    i:=1;

    while (i < = n) and (X[i] < = 0) do

    i:=i+1;

    if i > n then

    writeln ('folse')

    else

    begin

    k:=i;

    i:=i+1;

    while (i < = n) and (X[i] < = 0) do

    i:=i+1;

    if i > n then

    writeln ('folse')

    else

    begin

    f:=i;

    for i : = k + 1 to f - 1 do

    S:=S+X[i];

    writeln ('Сумма: ', S:5:2) ;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном массиве, состоящем из n вещественных элементов, вычислить: 1) Максимальный по модулю элемент массива 2) Сумму элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В одномерном массиве, вводимом с клавиатуры и состоящем из 10 вещественных элементов, вычислить: 1) номер максимального по модулю элемента массива; 2) сумму элементов массива, расположенных после первого положительного элемента.
Ответы (1)
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)
В одномерном массиве, состоящем из n целых элементов, вычислить: 1.) минимальный по модулю элемент массива; 2.) сумму модулей элементов массива, расположенных после первого элемента, равного нулю.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)