Задать вопрос
27 февраля, 20:02

В одномерном массиве, вводимом с клавиатуры и состоящем из 10 вещественных элементов, вычислить:

1) номер максимального по модулю элемента массива;

2) сумму элементов массива, расположенных после первого положительного элемента.

+5
Ответы (1)
  1. 27 февраля, 22:25
    0
    Program n1;

    const n=10;

    var a: array[1 ... n] of real;

    sum: real;

    i, i2: integer;

    b: boolean;

    begin

    i2:=1;

    b:=false;

    for i:=1 to n do begin

    readln (a[i]) ;

    if abs (a[i]) >abs (a[i2]) then i2:=i;

    end;

    writeln ('номер максимального по модулю: ', i2) ;

    sum:=0;

    for i:=1 to n do

    begin

    if b=false then

    begin

    if a[i]>0 then b:=true;

    end

    else

    sum:=sum+a[i];

    end;

    writeln ('сумма: ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном массиве, вводимом с клавиатуры и состоящем из 10 вещественных элементов, вычислить: 1) номер максимального по модулю элемента ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В одномерном массиве, состоящем из n вещественных элементов, вычислить: 1) Максимальный по модулю элемент массива 2) Сумму элементов массива, расположенных между первым и вторым положительными элементами.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
В одномерном массиве, состоящем из n целых элементов, вычислить: 1.) минимальный по модулю элемент массива; 2.) сумму модулей элементов массива, расположенных после первого элемента, равного нулю.
Ответы (1)
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)