Задать вопрос
15 февраля, 00:18

Задача на VBA: Дано число. Составить программу, которая определяет. входит ли в него цифра 3.

+3
Ответы (1)
  1. 15 февраля, 02:26
    0
    Дам 2 кода на с + + и на паскаль, попробуешь перевести на VBA. не сложно.

    с++

    int a, b, count (0) ;;

    cin>>a;

    while (a>0)

    {

    b=a%10;

    if (b==3) count++;

    a/=10;

    }

    if (count > 0) cout<<"OK";

    else cout<<"NO";

    pascal как то так

    uses crt;

    var a, b, count:integer;

    begin

    readln (a) ;

    count:=0;

    while a > 0 do

    begin

    b:=a mod 10;

    if b = 3then inc (count) ;

    a:=a div 10;

    end;

    if count > 0 then writeln ('ok')

    else

    writeln ('NO') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача на VBA: Дано число. Составить программу, которая определяет. входит ли в него цифра 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
дано целое двузначное число. Составить программу которая определяет входит ли в него цифра 4
Ответы (2)
Дано целое положительное трехзначное число n. Составить программу, которая определяет входит ли в него цифра 8.
Ответы (1)
Дано целое двухзначное положительное число n. Составьте программу, которая определяет, входит ли в него цифра 4. (Скорее всего по Поскалю надо решать)
Ответы (1)