Задать вопрос
5 марта, 21:32

Дано целое положительное трехзначное число n. Составить программу, которая определяет входит ли в него цифра 8.

+3
Ответы (1)
  1. 5 марта, 23:35
    0
    Var n:integer;

    Begin

    Write ('Введите трёхзначное число: ') ; ReadLn (n) ;

    n:=Abs (n) ;

    if (n div 100 = 8) or ((n div 10) mod 10 = 8) or (n mod 10 = 8) then WriteLn ('Входит')

    else WriteLn ('Не входит')

    End.

    Пример работы программы:

    Введите трёхзначное число: 85

    Входит
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое положительное трехзначное число n. Составить программу, которая определяет входит ли в него цифра 8. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано целое двухзначное положительное число n. Составьте программу, которая определяет, входит ли в него цифра 4. (Скорее всего по Поскалю надо решать)
Ответы (1)
дано целое двузначное число. Составить программу которая определяет входит ли в него цифра 4
Ответы (2)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)