Задать вопрос
8 сентября, 05:24

Дано целое двухзначное положительное число n. Составьте программу, которая определяет, входит ли в него цифра 4. (Скорее всего по Поскалю надо решать)

+4
Ответы (1)
  1. 8 сентября, 05:49
    0
    Program primer;

    Uses crt;

    var a: integer;

    begin clrscr;

    write ('Введите число a = ') ;

    readln (a) ;

    writeln;

    if ((a mod 10) = 4) or ((a div 10) = 4) then

    writeln ('Цифра 4 входит в число ')

    else

    writeln ('Цифра 4 не входит в число ') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое двухзначное положительное число n. Составьте программу, которая определяет, входит ли в него цифра 4. (Скорее всего по Поскалю ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано целое положительное трехзначное число n. Составить программу, которая определяет входит ли в него цифра 8.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1). Дано целое число Х. Составьте программу которая выясняет верно ли что 0 больше или равно Х и больше 1. 2). Дано целое число П. Составьте программу которая выясняет является им значение П кратное 3.
Ответы (1)