Задать вопрос
13 марта, 01:43

Даны n чисел. Найдите произведение максимального и минимального из них

+5
Ответы (1)
  1. 13 марта, 05:27
    0
    uses crt;

    var x, i, n, max, min:integer;

    begin

    readln (n) ;

    read (x) ;

    max:=x; min:=x;

    for i:=1 to n-1 do

    begin

    readln (x) ;

    if min > x then min:=x;

    if max < x then max:=x;

    end;

    writeln (min,' ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны n чисел. Найдите произведение максимального и минимального из них ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Найти произведение максимального и минимального чисел (Pascal ABC)
Ответы (2)
Дано трехзначное целое число. Найти произведение этого числа на разность максимального и минимального чисел, составленных их цифр исходного числа. Например для заданного числа 315 получим: 315 * (531 - 135) = 124740
Ответы (1)
Задан одномерный массив целых чисел. Вычислить сумму значений элементов, значения которых меньше половины значения максимального элемента чисел, но больше половины минимального элемента.
Ответы (1)