Задать вопрос
29 апреля, 00:39

С клавиатуры вводятся 3 числа. Найти количество и сумму четных чисел среди них. Если среди введенных четных нет, то вывести соответствующее сообщение.

+4
Ответы (1)
  1. 29 апреля, 02:50
    0
    Program Num3;

    Uses Crt;

    var a, b, c, n, s:integer;

    begin

    clrscr;

    write ('Введите 3 числа: ') ;

    readln (a, b, c) ;

    n:=0; s:=0;

    if (a mod 2) = 0 then

    begin

    n:=n+1;

    s:=s+a;

    end;

    if (b mod 2) = 0 then

    begin

    n:=n+1;

    s:=s+b;

    end;

    if (c mod 2) = 0 then

    begin

    n:=n+1;

    s:=s+c;

    end;

    if (n=0) then writeln ('Нету чётных чисел вообще! ')

    else writeln ('Количество чётных чисел:', n,'Их сумма: ', s) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся 3 числа. Найти количество и сумму четных чисел среди них. Если среди введенных четных нет, то вывести соответствующее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
С клавиатуры вводятся N чисел. Составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. Значение N и сами числа вводится с клавиатуры.
Ответы (2)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)