Задать вопрос
22 мая, 17:43

Найти произведение максимального и минимального чисел (Pascal ABC)

+3
Ответы (2)
  1. 22 мая, 18:17
    0
    Program maxmin;

    var l, i, n, min, max:integer;

    begin

    read (n) ;

    for i:=1 to n do begin

    max:=0;

    min:=10;

    read (l) ;

    if l
    if l>max then max:=l;

    end;

    writeln (max*min) ;

    end.

    to?
  2. 22 мая, 21:12
    0
    Program fofgogjoj;

    var

    arr: array[1 ... 1000] of byte;

    max_num, min_num: byte;

    i: byte;

    n, p:integer;

    begin

    randomize;

    Wriiteln ('Введите число n') ;

    Readln (n) ;

    for i : = 1 to n do begin

    arr[i] : = random (100) ;

    Write (arr[i]:3) ;

    end;

    max_num : = arr[1];

    for i : = 2 to n do

    if arr[i] > max_num then

    begin

    max_num : = arr[i];

    end;

    Writeln;

    Writeln ('Max = ', max_num) ;

    min_num : = arr[1];

    for i : = 2 to n do

    if arr[i] < min_num then

    begin

    min_num : = arr[i];

    end;

    Writeln;

    Writeln ('Min = ', min_num) ;

    P:=max_num*min_num;

    Writeln ('Произведение равно:', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти произведение максимального и минимального чисел (Pascal ABC) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Ввести с клавиатуры массив из N вещественных чисел. Найти разность максимального и минимального элементов. (Составить программу Pascal)
Ответы (1)