Задать вопрос
24 апреля, 12:20

Дана прямоугольная матрица mxn. определить есть в данном массиве строка в которой ровно два отрицательных элемента. Решить через Pascal

+1
Ответы (1)
  1. 24 апреля, 13:46
    0
    uses crt;

    var a:array[1 ... 99,1 ... 99] of integer;

    m, n, s, i, j:integer;

    begin

    write ('Введите m и n: ') ;

    readln (m, n) ;

    writeln ('Исходная матрица: ') ;

    for i:=1 to m do begin

    for j:=1 to n do begin

    a[i, j]:=random (10 - (-10) + 1) - 10;

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    s:=0;

    for i:=1 to m do begin

    for j:=1 to n do begin

    if a[i, j]<0 then s:=s+1;

    end;

    if s=2 then begin writeln ('Строка с двумя отрицательными элементами есть') ; halt; end; {если нужная строка найдена, программа выдаёт надпись о её нахождении и немедленно завершается}

    s:=0;

    end;

    writeln ('Строки с двумя отрицательными элементами нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана прямоугольная матрица mxn. определить есть в данном массиве строка в которой ровно два отрицательных элемента. Решить через Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)