Задать вопрос
12 августа, 13:23

Дано трёхзначное число. напишите программу которая определяет есть ли среди цифр заданного целого трёхзначного числа одинаковые

+4
Ответы (1)
  1. 12 августа, 14:41
    0
    var

    a : integer;

    begin

    read (a) ;

    if (a mod 10 = a div 100) or (a mod 10 = a div 10 mod 10) or (a div 100 = a div 10 mod 10) then write ('yes') else write ('no') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано трёхзначное число. напишите программу которая определяет есть ли среди цифр заданного целого трёхзначного числа одинаковые ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Напишите программу, которая: А) определяет, есть ли среди цифр заданного целого трехзначного числа одинаковые; Б) явл. ли число "перевертышем", т. е. Числом, десятичная запись которого читается одинаково слева направо и справа налево.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Да ну трёх значные числа. Напишите программу, который определяет: А) Есть ли среди цифр заданного целого трёх значного числа одинаковый 123 нет 121 да 222 да Б) Является ли число перевертышем то есть число десятичной записи которые читаются
Ответы (1)