Задать вопрос
18 июля, 19:46

Напишите программу, которая:

А) определяет, есть ли среди цифр заданного целого трехзначного числа одинаковые;

Б) явл. ли число "перевертышем", т. е. Числом, десятичная запись которого читается одинаково слева направо и справа налево.

+2
Ответы (1)
  1. 18 июля, 21:29
    0
    А) Program cifr;

    Uses crt;

    var n, l:integer; s:string;

    Begin

    read (n) ;

    str (n, s) ;

    l:=length (s) ;

    if (s[1]s[2]) and (s[2]s[3]) and (s[1]s[3])

    then begin writeln ('Одинаковых цифр нет') end

    else writeln ('Одинаковые цифры присутствуют') ;

    end.

    Б) Program Stroke;

    Uses Crt;

    Var s: string; n, i, j, l: integer;

    Begin

    ReadLn (n) ;

    str (n, s) ;

    l:=length (s) ;

    j:=0;

    for i : = 1 to l div 2 do begin

    if s[i]=s[length (s) - i+1]

    then j:=1 end;

    if j=1 then

    writeln ('Да, число является палиндромом')

    else writeln ('Нет, число не является палиндромом') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая: А) определяет, есть ли среди цифр заданного целого трехзначного числа одинаковые; Б) явл. ли число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 122 - нет 121 - перевертыш 222 - перевертыш
Ответы (1)
Дано трёхзначное число. Напишите в паскаль программу, которая определяет: Является ли число "перевёртышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево.
Ответы (1)
Дано натуральное число. Выяснить, является ли оно палиндромом ("перевертышем"), т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. Помогите написать на паскале
Ответы (1)
Да ну трёх значные числа. Напишите программу, который определяет: А) Есть ли среди цифр заданного целого трёх значного числа одинаковый 123 нет 121 да 222 да Б) Является ли число перевертышем то есть число десятичной записи которые читаются
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)