Задать вопрос
27 октября, 21:10

Да ну трёх значные числа. Напишите программу, который определяет:

А) Есть ли среди цифр заданного целого трёх значного числа одинаковый

123 нет

121 да

222 да

Б) Является ли число перевертышем то есть число десятичной записи которые читаются одинаково слева направо и справа налево

122 нет

121 перевертыш

222 перевертыш

+5
Ответы (1)
  1. 27 октября, 23:42
    0
    1.

    var a, c:integer; m:set of 0 ... 9; b:boolean;

    begin

    readln (a) ;

    m:=[];

    b:=false;

    while a>0 do

    begin

    c:=a mod 10;

    if c in m then b:=true;

    m:=m+[c];

    a:=a div 10;

    end;

    if b then writeln ('Да')

    else writeln ('Нет') ;

    end.

    Пример:

    121

    Да

    2.

    var a, b, c:integer;

    begin

    readln (a) ;

    c:=a;

    b:=0;

    while c>0 do

    begin

    b:=b*10+c mod 10;

    c:=c div 10;

    end;

    if a=b then writeln ('перевертыш')

    else writeln ('Нет') ;

    end.

    Пример:

    121

    перевертыш
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Да ну трёх значные числа. Напишите программу, который определяет: А) Есть ли среди цифр заданного целого трёх значного числа одинаковый 123 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 122 - нет 121 - перевертыш 222 - перевертыш
Ответы (1)
Напишите программу, которая: А) определяет, есть ли среди цифр заданного целого трехзначного числа одинаковые; Б) явл. ли число "перевертышем", т. е. Числом, десятичная запись которого читается одинаково слева направо и справа налево.
Ответы (1)
Дано трёхзначное число. Напишите в паскаль программу, которая определяет: Является ли число "перевёртышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево.
Ответы (1)
При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник? 1 Повтори 3 [Вперёд 50 Направо 20 Направо 25] 2 Повтори 3 [Вперёд 50 Направо 100 Направо 20] 3 Повтори 6 [Вперёд 50 Направо 10 Направо 20] 4 Повтори 6
Ответы (1)
Составьте программу, которая позволяет определить, является ли введенная строка перевертышем, то есть читается одинаково справа налево и слева направо
Ответы (1)