Задать вопрос
3 мая, 17:25

Составьте программу, определяющую максимальный элемент и его индексы матрицы А размером M x N

+3
Ответы (1)
  1. 3 мая, 18:56
    0
    Var a:array[1 ... 10,1 ... 10]of integer; неудобно var a:array[1 ... 10,1 ... 10]of integer;

    max, i1, j1, i, j, k, m, n:integer;

    begin

    readln (m, n) ;

    for i:=1 to m do

    for j:=1 to n do

    readln (a[i, j]) ;

    max:=a[1,1];

    i1:=1;

    j1:=1;

    for i:=1 to m do begin

    for j:=1 to n do begin

    if a[i, j]>max then begin max:=a[i, j]; i1:=i; j1:=j; end;

    end;

    end;

    writeln (max,' ', i1,' ', j1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, определяющую максимальный элемент и его индексы матрицы А размером M x N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Задача для Free Pascal. Дана матрица размером n*m. Найти седловую точку матрицы и напечатать ее индексы.
Ответы (1)
6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.
Ответы (1)
Задача на C++. Двумерный массив 5*5. Для каждой строки заданной матрицы определить и напечатать сумму элементов столбцов с чётными номерами. Для каждого столбца заданной матрицы найти и напечатать максимальный элемент.
Ответы (1)