Задать вопрос
24 июня, 19:03

Задача для Free Pascal.

Дана матрица размером n*m. Найти седловую точку матрицы и напечатать ее индексы. Седловой точкой называется элемент, имеющий наименьшее значение в строке и наибольшее в столбце

Каждый элемент матрицы должен быть введён вручную

+5
Ответы (1)
  1. 24 июня, 22:26
    0
    Const

    N = 3;

    M = 4;

    Var

    A:array[1 ... N, 1 ... M] of integer;

    i, j, Min, Max:integer;

    Begin

    WriteLn ('Введите матрицу A[', N,',', M,']:') ;

    For i: = 1 to N do

    For j: = 1 to M do

    Read (A[i, j]) ;

    WriteLn;

    For i: = 1 to N do

    Begin

    Min:=1;

    For j: = 2 to M do

    if A[i, Min]>A[i, j] then Min:=j;

    Max:=1;

    For j: = 2 to N do

    if A[Max, Min]
    if Max=i then WriteLn ('A[', i,',', Min,'] = ', A[i, Min])

    End;

    End.

    Пример:

    Введите матрицу A[3,4]:

    4 3 6 - 4

    2 - 3 - 9 - 5

    2 4 - 6 - 9

    A[1,4] = - 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача для Free Pascal. Дана матрица размером n*m. Найти седловую точку матрицы и напечатать ее индексы. Седловой точкой называется ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В массиве А[1 ... N, 1 ... N] определить номера строки и столбца какой-нибудь седловой точки. Некоторый элемент массива называется седловой точкой, если он является одновременно наименьшим в своей строке и наибольшим в своем столбце
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Оформить в виде подпрограмм-процедур в программе Pascal: Дана матрица действительных чисел M*N. Найти матрицу того же порядка, в которой элемент равен 1, если соответствующий ему элемент начальной матрицы больше, чем элемент, расположенный в его
Ответы (1)