Задать вопрос
24 марта, 00:03

Составьте программу, которая выводит на экран число сотен в заданном числе, если оно трёхзначное, а в противном случае сообщает: "число не трёхзначное".

+5
Ответы (1)
  1. 24 марта, 01:10
    0
    Решение на С/C + +:

    #include

    using namespace std;

    int main ()

    {

    int number;

    cin>>number;

    number = (number-number%10) / 10;

    //в результате остаётся число десятков, т. е. число без единиц

    number = (number-number%10) / 10; / / тут уже число сотен без десятков

    if (number==0) / / если в результате будет 0 десятков, то выводим текст

    {

    cout<<"chislo ne trehznachnoe";

    }

    else / / в противном случае десятки будут

    {

    cout<
    }

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая выводит на экран число сотен в заданном числе, если оно трёхзначное, а в противном случае сообщает: "число не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Написать программу, которая выводит на экран результаты следующих действий: 27-5= 11+21= 32/2= 2+2*2= (2+2) * 2= Написать программу, которая выводит на экран результаты следующих действий: 21-4= 21+11= 43/3= 3+3*3= (3+3) * 3=
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае, если введенное число отрицательно. В противном случае на экран выводится сообщение ошибка
Ответы (2)
Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) Дано целое число.
Ответы (1)