Задать вопрос
14 января, 06:17

напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае, если введенное число отрицательно. В противном случае на экран выводится сообщение ошибка

+3
Ответы (2)
  1. 14 января, 07:52
    0
    var a:integer;

    begin

    readln (a) ;

    if (a<0) then a:=sqr (a) ;

    writeln (a) else writeln ('Error') ;

    end.
  2. 14 января, 09:52
    0
    type Cl = class

    a:integer;

    constructor Create (b:integer) ;

    procedure SetVal (b:integer) ;

    function GetVal:integer;

    procedure Sq;

    end;

    constructor Cl. Create (b:integer) ;

    begin

    a : = b;

    end;

    procedure Cl. SetVal (b:integer) ;

    begin

    a : = b;

    end;

    function Cl. GetVal:integer;

    begin

    GetVal : = a;

    end;

    procedure Cl. Sq;

    begin

    if a < 0 then

    writeln ('a ^ 2 = ', a * a)

    else

    writeln ('Error') ;

    end;

    var

    Obj:Cl;

    a : integer;

    begin

    write ('a = ') ;

    readln (a) ;

    Obj : = Cl. Create (a) ;

    Obj. Sq;

    Readln;

    Obj. Destroy;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае, если введенное число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если целое число М, введенное с клавиатуры, делится на целое число Н, введенное с клавиатуры, с остатком равным 2, то вывести на экран целую часть от деления М на Н, в противном случае - сообщение "при делении ... на ... остаток не равен 2"
Ответы (1)
Написать программу которая определяет: если целое число M делится на целое число N, то на экране выводит часть деления, в противном случае выводится сообщение "M и N нацело не делиться" в pascal
Ответы (2)
С клавиатуры водит число напишите программу которая вычитает из него 10, если оно отрицательно, в противном случае прибавляет к нему 10 и выводит на экран
Ответы (1)
С + + с клавиатуры вводится целое число. если введенное число отрицательное, то возвести его в квадрат, оставить число без изменений в противном случае.
Ответы (1)
Удвоить трехзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае. Если введенное число не трехзначное, вывести сообщение об ошибке.
Ответы (1)