Задать вопрос
22 марта, 15:49

дано натуральное число N. Составте программу, котора определяет, сколько раз в числе N содержится наибольшая цифра этого числа.

+5
Ответы (1)
  1. 22 марта, 19:04
    0
    var

    max, c, t, count:integer;

    begin

    write ('c = ') ;

    readln (c) ;

    t : = c;

    max : = t mod 10;

    while t 0 do

    begin

    if max < t mod 10 then

    max : = t mod 10;

    t : = t div 10;

    end;

    t : = c;

    count : = 0;

    while t 0 do

    begin

    if t mod 10 = max then

    count : = count + 1;

    t : = t div 10;

    end;

    writeln ('Count = ', count) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дано натуральное число N. Составте программу, котора определяет, сколько раз в числе N содержится наибольшая цифра этого числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Информатика. Паскаль. Дано натуральное число N. Составить программу, которая определяет, сколько цифр этого числа кратны трем. P. S т. е мало того что нам нужно определить кратность каждой цифры этого числа ина выходе получит сколько этих чисел.
Ответы (1)
Дано натуральное чсло N. Составте программу, которая определяет, является ли последовательность цифр этого числа (при просмотре их справа налево) упорядоченной по возрастанию.
Ответы (1)