Задать вопрос
6 февраля, 09:18

Дано натуральное чсло N. Составте программу, которая определяет, является ли последовательность цифр этого числа (при просмотре их справа налево) упорядоченной по возрастанию.

+1
Ответы (1)
  1. 6 февраля, 12:35
    0
    var

    x, n:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    x : = n mod 10;

    n : = n div 10;

    while n > 0 do

    begin

    if n mod 10 < x then

    begin

    writeln ('Последовательность неупорядочена по возрастанию') ;

    readln;

    Exit;

    end;

    x : = n mod 10;

    n : = n div 10;

    end;

    writeln ('Последовательность упорядочена по возрастанию') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное чсло N. Составте программу, которая определяет, является ли последовательность цифр этого числа (при просмотре их справа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу для паскаль! Дано натуральное число. Установить, является ли последовательность его цифр при просмторе их справа налево упорядоченной по возрастанию.
Ответы (1)
Дано натуральное число. Установить, является ли последовательность его цифр при просмторе их справа налево упорядоченной по возрастанию. С помощью repeat.
Ответы (1)
Дано натуральное число. Установить является ли последовательность его цифр при просмотре их слева направо упорядоченной по неубыванию. Например, для чисел 5321 и 9663 ответ положительный, для чисел 7820 и 9663 отрицательный и т. п.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)