Задать вопрос
12 октября, 21:37

Напишите программу для паскаль! Дано натуральное число. Установить, является ли последовательность его цифр при просмторе их справа налево упорядоченной по возрастанию.

+4
Ответы (1)
  1. 13 октября, 01:25
    0
    Var n, k:integer; b:boolean;

    begin

    write ('n=') ; readln (n) ;

    b:=true; k:=0;

    while n0 do

    begin

    b:=b and (n mod 10>k) ;

    k:=n mod 10;

    n:=n div 10;

    end;

    if b then writeln ('Цифры числа упорядочены')

    else writeln ('Цифры числа не упорядочены') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для паскаль! Дано натуральное число. Установить, является ли последовательность его цифр при просмторе их справа налево ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число. Установить, является ли последовательность его цифр при просмторе их справа налево упорядоченной по возрастанию. С помощью repeat.
Ответы (1)
Дано натуральное чсло N. Составте программу, которая определяет, является ли последовательность цифр этого числа (при просмотре их справа налево) упорядоченной по возрастанию.
Ответы (1)
Дано натуральное число. Установить является ли последовательность его цифр при просмотре их слева направо упорядоченной по неубыванию. Например, для чисел 5321 и 9663 ответ положительный, для чисел 7820 и 9663 отрицательный и т. п.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)