Задать вопрос
17 апреля, 13:26

Информатика. Паскаль. Дано натуральное число N. Составить программу, которая определяет, сколько цифр этого числа кратны трем. P. S т. е мало того что нам нужно определить кратность каждой цифры этого числа ина выходе получит сколько этих чисел.

+3
Ответы (1)
  1. 17 апреля, 15:22
    0
    var

    N, count:integer;

    begin

    write ('N = ') ;

    readln (N) ;

    count : = 0;

    while N > 0 do

    begin

    if (N mod 10) mod 3 = 0 then

    count : = count + 1;

    N : = N div 10;

    end;

    writeln ('Count = ', count) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Информатика. Паскаль. Дано натуральное число N. Составить программу, которая определяет, сколько цифр этого числа кратны трем. P. S т. е ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Исполнитель "Умник" получает на входе число, обрабатывает его, и на выходе выдает другое число. Например: на входе 100 = на выходе 25; на входе 48 = на выходе 3; на входе 232 = на выходе 29; на входе 448 = на выходе 7.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)