Задать вопрос
14 января, 14:52

Ввести целое число и определить количество четных и нечетных цифр.

+4
Ответы (1)
  1. 14 января, 18:49
    0
    Pascal:

    var n, kc, kn:integer;

    begin

    write ('N = ') ;

    readln (n) ;

    kc:=0;

    kn:=0;

    while (n0) do

    begin

    if (n mod 10 mod 2 = 0) then inc (kc) else inc (kn) ;

    n:=n div 10;

    end;

    writeln ('Кол-во четных цифр: ', kc) ;

    writeln ('Кол-во нечетных цифр: ', kn) ;

    end.

    C++:

    #include

    using namespace std;

    int main ()

    {

    int n, kn = 0, kc = 0;

    cout <<"N = ";

    cin >>n;

    while (n!=0)

    {

    if (n%10%2==0)

    ++kc;

    else + + kn;

    n/=10;

    }

    cout <<"Кол-во четных цифр: " <
    <<"Кол-во нечетных цифр: " <
    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести целое число и определить количество четных и нечетных цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
2. Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Найти минимальное число, большее 300, которое нацело делится на 19.2) С клавиатуры вводится натуральное число n. Найти количество цифр этого числа, их сумму, количество четных и нечетных цифр, сколько цифр в числе делится на 3.
Ответы (1)