Задать вопрос
27 июля, 00:18

Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных. вывести новые числа.

+4
Ответы (1)
  1. 27 июля, 04:00
    0
    Не самый рациональный метод решения, но как говорится чем смог тем помог)

    var a, b, c, x, kc, kn, k1, k2:integer;

    begin

    kc:=1;

    kn:=1;

    k1:=0;

    k2:=0;

    a:=0;

    b:=0;

    writeln ('Введите число x') ;

    read (x) ;

    while x>0 do begin

    c:=x mod 10;

    if c mod 2=0 then begin

    inc (k1) ;

    a:=a+c*kc;

    kc:=kc*10;

    end;

    if c mod 20 then begin

    inc (k2) ;

    b:=b+c*kn;

    kn:=kn*10;

    end;

    x:=x div 10;

    end;

    if k1>k2 then writeln ('Четных больше нечетных') else if k1=k2 then writeln ('Количество четных = количеству нечетных') else writeln ('Четных меньше нечетных') ;

    writeln (a,' ', b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)