Задать вопрос
14 января, 14:39

Помогите в паскале составить

прогу. если можно на уровне 9 го класса

Составить программу для вычисления значения функции на отрезке [a, b] с шагом 1.

+5
Ответы (1)
  1. 14 января, 18:09
    0
    Мы взяли функцию f (x) = sin (x) - 2*cos (x).

    В процедуру-функцию function можно вставлять любые функции

    program func;

    uses Crt;

    var a, b, x, y:real;

    function f (var x:real) : real;

    begin

    f:=sin (x) - 2*cos (x) ;

    end;

    begin

    ClrScr; {Очистка экрана}

    Write (' a = ') ; ReadLn (a) ;

    Write (' b = ') ; ReadLn (b) ;

    WriteLn;

    x:=a;

    while x<=b do

    begin

    y:=f (x) ;

    WriteLn ('y (', x:1:0, ') = ', y:4:2) ;

    x:=x+1;

    end;

    ReadLn;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите в паскале составить прогу. если можно на уровне 9 го класса Составить программу для вычисления значения функции на отрезке [a, b] ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1. найти функцию y=4x-5 на отрезке [1; 30] с шагом h=3. 2. Найти функцию y=5x²-2x+1 на отрезке [-5; 5] с шагом h=2. Сделать в Паскале.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
В паскале в 3 циклах: for; repeat; white. Вычислить и напечатать значения функции и соответствующие им значения аргументов x, y. z=2xy-2yx при изменении первого аргумента x[-1; 1] с шагом 0.1 и второго аргумента y[2; 2] с шагом 0.2.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)