Задать вопрос
2 июня, 16:46

1) Найти минимальное число, большее 300, которое нацело делится на 19.2) С клавиатуры вводится натуральное число n. Найти количество цифр этого числа, их сумму, количество четных и нечетных цифр, сколько цифр в числе делится на 3.

+5
Ответы (1)
  1. 2 июня, 19:49
    0
    1)

    var n:integer;

    begin

    n:=301;

    while n mod 190 do n:=n+1;

    writeln (n,' / 19 = ', n div 19) ;

    end.

    Пример:

    304 / 19 = 16

    2)

    var n, c, k1, k2, s, k3:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    k1:=0; k2:=0; s:=0; k3:=0;

    while n > 0 do

    begin

    c:=n mod 10;

    if c mod 2=0 then k1:=k1+1 else k2:=k2+1;

    s:=s+c;

    if c mod 3=0 then k3:=k3+1;

    n: = n div 10;

    end;

    writeln ('количество цифр числа = ', k1+k2) ;

    writeln ('их сумма = ', s) ;

    writeln ('количество четных цифр = ', k1) ;

    writeln ('количество нечетных цифр = ', k2) ;

    writeln ('количество цифр, кратных 3 = ', k3) ;

    end.

    Пример:

    n = 2745194

    количество цифр числа = 7

    их сумма = 32

    количество четных цифр = 3

    количество нечетных цифр = 4

    количество цифр, кратных 3 = 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Найти минимальное число, большее 300, которое нацело делится на 19.2) С клавиатуры вводится натуральное число n. Найти количество цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Дано натуральное число. Определить: а) сколько раз в нем встречается цифра а; б) количество его цифр, кратных z (значение z вводится с клавиатуры; z 2, 3, 4) ; в) сумму его цифр, больших a (значение a вводится с клавиатуры; 0 a 8) ;
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)