Задать вопрос
7 января, 17:04

Расcтавить по возрастанию элементы 2 строки в двумерном массиве z[5,6]. Язык Паскаль

+4
Ответы (1)
  1. 7 января, 20:28
    0
    Var

    a: array [1 ... 6, 1 ... 5] of integer;

    i, j, n : longint;

    begin

    for i: = 1 to 6 do

    for j: = 1 to 5 do

    read (a[i, j]) ;

    Writeln () ;

    for j: = 1 to 5 do

    for i: = 1 to 5 do

    if a[2, i] > a[2, j] then swap (a[2, i], a[2, j]) ;

    for i: = 1 to 6 do begin

    for j: = 1 to 5 do

    write (a[i, j], ' ') ;

    Writeln () ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Расcтавить по возрастанию элементы 2 строки в двумерном массиве z[5,6]. Язык Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
В двумерном массиве A (N, N) все элементы первой строки заменить элементами последней строки. N=3. Массив заполняется с клавиатуры.
Ответы (1)