Задать вопрос
17 марта, 05:45

написать программу на паскале: в целочисленном одномерном массиве из N (N<=50) элементов. Найти номера элементов кратных 3. Если таких элементов нет, то сообщить об этом. Массив заполнить вручную.

+2
Ответы (1)
  1. 17 марта, 08:36
    0
    uses crt;

    var

    a:array[1 ... 50] of integer;

    i, n, k:integer;

    begin

    clrscr;

    k:=0;

    write ('Введите количество элементов массива') ; read (n) ;

    writeln ('Введите массив:') ;

    for i:=1 to n do

    read (a[i]) ;

    write ('Номера элементов, кратных 3:') ;

    for i:=1 to n do

    if (a[i] mod 3=0) then

    begin

    k:=k+1;

    write (i,' ') ;

    end;

    if k=0 then write ('Таких элементов нет.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу на паскале: в целочисленном одномерном массиве из N (N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Прошу, помогите написать программу! (Тема - Операции над массивами.) Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры находит число положительных чисел в массиве.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)